SMA + 123solar on Raspberry Pi

485solar-get protocol http://sourceforge.net/projects/solarget/
Post Reply
Muffin
Posts: 4
Joined: Mon Sep 09, 2013 6:42 pm

SMA + 123solar on Raspberry Pi

Post by Muffin » Mon Sep 09, 2013 7:04 pm

Hi,
I have two solar installations, one with Aurora inverter + ATC1000 RS485<->TCP converter and a Raspberry Pi with Raspbian Wheezy installed. After many hours searching works this fine.
My other installation is one with a SMA SB3800 inverter, also with the original RS485 piggyback.
When i try to combine this two inverters on my Raspi, will the Aurora send data, but the SMA will stay dead.
btw: I have installed sma_get and yasdi.
So, I try again with a new Raspi, and only install sma_get + yasdi. The communication did i with a usb to Rs485 converter based on the FTDI chip. When i run yasdishell: I see com 1 is opened at 1200 baud and i can communicate with the SMA. When i close yasdishell, the com port will be closed. So far, so good i think. Now, I can install 123solar and it must be run ... but no ... no connection ... What can be wrong?
Maybe the difference in communication speed, Aurora is 19200bd and SMA is 1200bd?
Anybody who can help me?

jeanmarc
Posts: 1866
Joined: Thu Aug 29, 2013 7:16 am

Re: SMA + 123solar on Raspberry Pi

Post by jeanmarc » Mon Sep 09, 2013 7:28 pm

Hi,
If you have on the same RS485 bus the Aurora and the SMA, are you able to communicate with both ? (Using aurora and sma-get)

Muffin
Posts: 4
Joined: Mon Sep 09, 2013 6:42 pm

Re: SMA + 123solar on Raspberry Pi

Post by Muffin » Tue Sep 10, 2013 6:54 pm

jeanmarc wrote:Hi,
If you have on the same RS485 bus the Aurora and the SMA, are you able to communicate with both ? (Using aurora and sma-get)
Hi Jean-Marc,
Like I said, on my first installation with the SMA and the Aurora on the same bus, it is only possible to communicate with the Aurora. This bus has a com to IP converter ATC1000. So, because that will not work, I tried with another converter: A RS485 to USB (FTDI) converter, on a separate Raspi, new installed with Raspbian Wheezy, sma_get and Yasdi. In this configuration, you can run Yasdishell, a little testprogram who opens a com port (com1) on 1200bd. This communication works. But not in 123solar, Why? :roll:

jeanmarc
Posts: 1866
Joined: Thu Aug 29, 2013 7:16 am

Re: SMA + 123solar on Raspberry Pi

Post by jeanmarc » Tue Sep 10, 2013 8:00 pm

Hi,
It might work with Yasdishell but not with sma-get :?
Besides 123solar, does sma-get work from the commande line ?
Good luck

Muffin
Posts: 4
Joined: Mon Sep 09, 2013 6:42 pm

Re: SMA + 123solar on Raspberry Pi

Post by Muffin » Mon Sep 16, 2013 6:00 pm

Hi Jeanmarc,

Probably, there is something wrong with yasdi.ini, In yasdishell i get the error: yasdi.ini is not found or is unreadable. Normally, yasdi.ini is placed in the directory /etc i guess. I 've changed now the attribute to 0755 and I can search and find the inverter with his s/n. However, sma_get will not communicate. :roll:

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests