[SOLVED] Undetected FTDI [RPi ArchLinux]

Talks about solar stuff
jeanmarc
Posts: 2023
Joined: Thu Aug 29, 2013 7:16 am

Re: Undetected FTDI [RPi ArchLinux]

Post by jeanmarc » Sat Jul 26, 2014 5:41 am

What dmesg | tail return when you unplug/replug it ?
It's like the port is dead :?

Thyxx
Posts: 21
Joined: Sun Jul 13, 2014 3:10 pm

Re: Undetected FTDI [RPi ArchLinux]

Post by Thyxx » Sat Jul 26, 2014 9:13 am

jeanmarc wrote:What dmesg | tail return when you unplug/replug it ?

Code: Select all

 
pi@raspberrypi ~ $ dmesg | tail
[   10.412596] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[   16.192403] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[   21.429061] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   23.024965] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[   25.242141] Adding 102396k swap on /var/swap.  Priority:-1 extents:1 across:102396k SSFS
[  363.260658] usbcore: registered new interface driver usbserial
[  363.260783] usbcore: registered new interface driver usbserial_generic
[  363.260991] usbserial: USB Serial support registered for generic
[  363.273271] usbcore: registered new interface driver ftdi_sio
[  363.273416] usbserial: USB Serial support registered for FTDI USB Serial Device

Code: Select all

pi@raspberrypi ~ $ dmesg | tail
[35027.897925] usb 1-1.2: No support over 500mA
[35043.246940] usb 1-1.2: USB disconnect, device number 9
[35045.276048] usb 1-1.3: new full-speed USB device number 10 using dwc_otg
[35045.570394] usb 1-1.3: unable to read config index 0 descriptor/start: -32
[35045.570431] usb 1-1.3: chopping to 0 config(s)
[35045.571141] usb 1-1.3: string descriptor 0 read error: -71
[35045.571179] usb 1-1.3: New USB device found, idVendor=0403, idProduct=6001
[35045.571201] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[35045.571744] usb 1-1.3: no configuration chosen from 0 choices
[35045.571769] usb 1-1.3: No support over 500mA

jeanmarc
Posts: 2023
Joined: Thu Aug 29, 2013 7:16 am

Re: Undetected FTDI [RPi ArchLinux]

Post by jeanmarc » Sat Jul 26, 2014 10:47 am

Did you use an USB hub ? It seem like it does "No support over 500mA"

Thyxx
Posts: 21
Joined: Sun Jul 13, 2014 3:10 pm

Re: Undetected FTDI [RPi ArchLinux]

Post by Thyxx » Sat Jul 26, 2014 4:42 pm

jeanmarc wrote:Did you use an USB hub ? It seem like it does "No support over 500mA"
No.
Raspberry Pi <--- USB Cable AB ---> Converter <--- RJ12 Cable --->Inverter

jeanmarc
Posts: 2023
Joined: Thu Aug 29, 2013 7:16 am

Re: Undetected FTDI [RPi ArchLinux]

Post by jeanmarc » Sat Jul 26, 2014 5:28 pm

That could be the issue. Rasberry have low powered USB (it has been reviewed in latest version)
You may need a powered USB hub or have a self powered converter..
Even tough it's weird, many people use RS485 converters with Rasp pi without any issue.

Thyxx
Posts: 21
Joined: Sun Jul 13, 2014 3:10 pm

Re: Undetected FTDI [RPi ArchLinux]

Post by Thyxx » Sun Aug 03, 2014 5:26 pm

Solved !

The différent USB cables tested were too long.
With a shorter cable, everything works.

Walter62
Posts: 32
Joined: Thu Aug 29, 2013 11:40 am
Location: Italia
Contact:

Re: [SOLVED] Undetected FTDI [RPi ArchLinux]

Post by Walter62 » Sun Aug 03, 2014 9:10 pm

good news, but the problem isn't the length of cable but the quality of cable, in every way the problem is solved

Thyxx
Posts: 21
Joined: Sun Jul 13, 2014 3:10 pm

Re: [SOLVED] Undetected FTDI [RPi ArchLinux]

Post by Thyxx » Tue Aug 05, 2014 11:11 am

Walter62 wrote:good news, but the problem isn't the length of cable but the quality of cable, in every way the problem is solved
No, the problem is the length of the cable...
I've tested with different cables of different brands (I have a good stock at home) and only the USB cable with a length of less than 3 meters work (whatever brand)

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests