Unable to connect with Aurora after upgrade

aurora protocol http://www.curtronics.com/Solar/
lextar
Posts: 7
Joined: Fri May 30, 2014 10:46 am

Unable to connect with Aurora after upgrade

Post by lextar » Fri May 30, 2014 11:56 am

Hi,
I upgraded 123solar to the latest version and now It does not connect with aurora.
I'm using remserial to connect to a remote serial port of the serial to TCP/IP converter.

This is the error I get:

aurora -a 2 -c -T -R 1500 -d0 -e -E /dev/remserial1 return :

error : /

If I run the command AS ROOT from the terminal it does work!
I think it' s a permission problem, because the device "remserial1" is owned by root and 123solar is running as www-data
How can I resolve that?
Thank you
Alex

jeanmarc
Posts: 1867
Joined: Thu Aug 29, 2013 7:16 am

Re: Unable to connect with Aurora after upgrade

Post by jeanmarc » Fri May 30, 2014 12:10 pm

Hi,
It might be better to change remserial1 ownership. Usually com ports are owned by uucp group (check for your distro), then : chgrp uucp /dev/remserial1
Then give permission for www-data user : usermod -a -G uucp www-data

lextar
Posts: 7
Joined: Fri May 30, 2014 10:46 am

Re: Unable to connect with Aurora after upgrade

Post by lextar » Fri May 30, 2014 1:17 pm

Hi jean,
Thank you for the reply
I already tried changing groups but remserial1 is owned by the group root and for some strange reason I can't change the group. Remserial1 is a virtual device that is created when I launch the remserial executable. Remserial can be run only as root...

http://lpccomp.bc.ca/remserial/

If i try to launch it with an user without root privileges, it doesn't start !

with the old version (1.5.5) it was working all perfectly !

jeanmarc
Posts: 1867
Joined: Thu Aug 29, 2013 7:16 am

Re: Unable to connect with Aurora after upgrade

Post by jeanmarc » Fri May 30, 2014 1:45 pm

If you can't run remserial as user maybe try something else like 'Socat'.

123solar run now as 'www' user for ease, security and performance reasons. It would be dangerous to give root membership to 'www'.
I never understand why people use eth/serial converter. It's only up to 100m where you can go up to 2000m with RS485 :geek:

lextar
Posts: 7
Joined: Fri May 30, 2014 10:46 am

Re: Unable to connect with Aurora after upgrade

Post by lextar » Fri May 30, 2014 1:48 pm

Tried also socat, but the remote serial is behind a router and I have timeout problems...
The only thing that works is a modified version of remserial:

http://sourceforge.net/projects/remserialfordyn/

jeanmarc
Posts: 1867
Joined: Thu Aug 29, 2013 7:16 am

Re: Unable to connect with Aurora after upgrade

Post by jeanmarc » Fri May 30, 2014 1:57 pm

Maybe chmod 777 /dev/remserial1 :?:

lextar
Posts: 7
Joined: Fri May 30, 2014 10:46 am

Re: Unable to connect with Aurora after upgrade

Post by lextar » Fri May 30, 2014 2:47 pm

Still nothing..

lrwxrwxrwx 1 root root 10 mag 30 14:35 remserial1 -> /dev/pts/

I'm using serial/eth converter because the machine i'm using for logging is not in the same place od the inverter! I'm using a remote server and not a local one, the only solution is to use a serial/eth convetret :(

jeanmarc
Posts: 1867
Joined: Thu Aug 29, 2013 7:16 am

Re: Unable to connect with Aurora after upgrade

Post by jeanmarc » Fri May 30, 2014 3:42 pm

It's odd that you can't change the device group. What is your distro ? What are other com port membership ls -l /dev/tty* ?

lextar
Posts: 7
Joined: Fri May 30, 2014 10:46 am

Re: Unable to connect with Aurora after upgrade

Post by lextar » Fri May 30, 2014 5:33 pm

I'm running Ubuntu 12.04.4 LTS x64.
other com ports are with user root and group tty, some other ports are under root user and dialout group!

jeanmarc
Posts: 1867
Joined: Thu Aug 29, 2013 7:16 am

Re: Unable to connect with Aurora after upgrade

Post by jeanmarc » Fri May 30, 2014 5:49 pm

usermod -a -G dialout www-data and tty :?:

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests