Test Communication Errors

aurora protocol http://www.curtronics.com/Solar/
Post Reply
morreale
Posts: 25
Joined: Sun Mar 20, 2016 9:31 pm

Test Communication Errors

Post by morreale » Tue Mar 22, 2016 12:30 am

Why does it include -3 when I have single phase chosen?

Code: Select all

aurora -a 2 -c -T -Y6 -d0 -e -3 /dev/ttyUSB0 return : 

error : / 
differences

Code: Select all

pi@aurora:~ $ aurora -a 2 -c -T -Y6 -d0 -e -3 /dev/ttyUSB0
20160321-18:26:08   336.903870       0.174815      58.895920     335.883484       0.234430      78.741035     247.332840       0.548456      89.986580      59.973610      65.379662      28.462517      28.162056       35.728       69.604        0.000      405.403     1473.365    12070.069    12070.003
20160321-18:26:10: aurora: ERROR: Received bad return code (-1 59 61)

Code: Select all

pi@aurora:~ $ aurora -a 2 -c -T -Y6 -d0 -e /dev/ttyUSB0
20160321-18:26:20   336.943115       0.174815      58.902782     333.293274       0.237652      79.207817     247.034073       0.442392      94.053253      59.972172      68.099960      28.457010      28.157768       35.728       69.604        0.000      405.403     1473.365    12070.070    12070.004    OK


Thanks,
Corey

jeanmarc
Posts: 1853
Joined: Thu Aug 29, 2013 7:16 am

Re: Test Communication Errors

Post by jeanmarc » Tue Mar 22, 2016 7:21 am

I guess you choose phase inverter in 'Configure your inverter(s)'. Didn't you ?

jeanmarc
Posts: 1853
Joined: Thu Aug 29, 2013 7:16 am

Re: Test Communication Errors

Post by jeanmarc » Tue Mar 22, 2016 7:36 am

Ok that's a bug, it is corrected. Thanks

morreale
Posts: 25
Joined: Sun Mar 20, 2016 9:31 pm

Re: Test Communication Errors

Post by morreale » Tue Mar 22, 2016 1:53 pm

awesome. thanks so much!

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests