Effekta not working anymore with 1.6.5.5

others protocols
mstuetz
Posts: 102
Joined: Sun Dec 29, 2013 1:20 pm

Effekta not working anymore with 1.6.5.5

Post by mstuetz » Thu Aug 21, 2014 11:29 am

Hi!
I just did a new installation with latestet 123solar code and effekta.
Unfortunately with the new version, 123solar stops immediately after manual start.
The error messages i get are:

21/08/2014 11:15:21 Starting 123Solar

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 62 100 55 100 7 81 10 --:--:-- --:--:-- --:--:-- 180
PHP Notice: Undefined variable: I3V in /var/www/123solar/scripts/123solar.php on line 147
...
PHP Notice: Undefined variable: G2P in /var/www/123solar/scripts/123solar.php on line 169
PHP Notice: Undefined variable: G3P in /var/www/123solar/scripts/123solar.php on line 169
PHP Fatal error: Cannot redeclare readfromfile() (previously declared in /var/www/123solar/scripts/protocols/effekta.php:15) in /var/www/123solar/scripts/protocols/effekta.php on line 40

The "Notice" messages are ok, since the variables were not explicit defined and should not be a problem.
The Fatal error seems to be caused by calling effekta.php more then once in parallel. Line 40 is actually the end of the function readfromfile() in the script.
Any idea, why we get the fault with the new version? What was changed an would maybe needed to be considered in effekta.php?
BTW: According to debug site the values are ok. Communication seems to be ok, too.
Cheers,
Mario

jeanmarc
Posts: 1917
Joined: Thu Aug 29, 2013 7:16 am

Re: Effekta not working anymore with 1.6.5.5

Post by jeanmarc » Thu Aug 21, 2014 3:23 pm

Hi,
Sorry for the troubles. The latest is actually 1.6.5.6 ;)
The Fatal error is certainly the problem. Which version did previously work fine ?

mstuetz
Posts: 102
Joined: Sun Dec 29, 2013 1:20 pm

Re: Effekta not working anymore with 1.6.5.5

Post by mstuetz » Thu Aug 21, 2014 3:40 pm

Previous version was/is 1.5.5. There still no problems with same scripts.

jeanmarc
Posts: 1917
Joined: Thu Aug 29, 2013 7:16 am

Re: Effekta not working anymore with 1.6.5.5

Post by jeanmarc » Thu Aug 21, 2014 4:57 pm

pfew that's pretty old. effekta files weren't even include in this one :shock:
I bet i know why, you can only define once a function. 123solar now compile once and run until the end of the world ;)
Previously, it compile on each request. You see, it's more CPU wise now than it was..

So, if you want to use function, you need to include_once or skip functions in protocols..

Code: Select all

<?php
include_once 'myreadfromfilefunction.php';

.. then the rest of effekta.php

mstuetz
Posts: 102
Joined: Sun Dec 29, 2013 1:20 pm

Re: Effekta not working anymore with 1.6.5.5

Post by mstuetz » Wed Aug 27, 2014 12:44 pm

Thx for the info.
Effekta code is fixed. There were also naming issues of some variables (e.g. $GP -> $G1P) which had also to be adapted.
I will send you actual effekta implementation files for next releases and will update modpoll site.
Cheers,
Mario

mstuetz
Posts: 102
Joined: Sun Dec 29, 2013 1:20 pm

Re: Effekta not working anymore with 1.6.5.5

Post by mstuetz » Sun Aug 31, 2014 7:30 am

Unfortunately there is one more issue:
After the night, 123solar doest not start anymore. Only a manual start gets it running again.
What was changed on the starting process? Do i have to change anything in the xx_startup.php script?

jeanmarc
Posts: 1917
Joined: Thu Aug 29, 2013 7:16 am

Re: Effekta not working anymore with 1.6.5.5

Post by jeanmarc » Sun Aug 31, 2014 7:46 am

Did you reboot each day ? At which time does it bug ? is it really each days ?
You may enable debug and return the log output.

mstuetz
Posts: 102
Joined: Sun Dec 29, 2013 1:20 pm

Re: Effekta not working anymore with 1.6.5.5

Post by mstuetz » Sun Aug 31, 2014 12:32 pm

Hi again!
I turned on debug, lets see what will be tomorrow morning.
What messages should actually be in the 123solar.err log after the start? Is there any other debug/log which is interesting for this issue?
How does the start get triggered? Has it something to do with the sunrise?

There is also another inelegance with the new version:
When i keep the broswer open watching the logger, the meter on the right showing the actual delivered power flaps in a 10 sec. rhythm. from real power with the max.delivered power@xx at the bottom to 0 Watt actual and 0 W@0. Any idea why?
Image Image

Little additional hint: "leistung" should be written with a capital "L" in german translation.

Cheers,
Mario

jeanmarc
Posts: 1917
Joined: Thu Aug 29, 2013 7:16 am

Re: Effekta not working anymore with 1.6.5.5

Post by jeanmarc » Sun Aug 31, 2014 2:21 pm

123solar.err should be empty in a perfect system ;)
Yes, the start/stop is based of the sunrise/sunset. If the live datas goes to zero, it mean your data are too old (at least 30 sec old). That could happen if you have a bad connection and/or a slow pooling.
I'll correct the translation. Thanks

mstuetz
Posts: 102
Joined: Sun Dec 29, 2013 1:20 pm

Re: Effekta not working anymore with 1.6.5.5

Post by mstuetz » Wed Sep 03, 2014 5:43 am

Hi!
After some changes in effekta_startup.php (php warnings) 123solar runs stable now.
The only messages i get in 123solar.err are:

Code: Select all

100    70  100    20  100    50     30     75 --:--:-- --:--:-- --:--:--   166
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    70  100    20  100    50     29     74 --:--:-- --:--:-- --:--:--   167
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    70  100    20  100    50      9     23  0:00:02  0:00:02 --:--:--   167
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    70  100    20  100    50     30     76 --:--:-- --:--:-- --:--:--   167
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    70  100    20  100    50     30     75 --:--:-- --:--:-- --:--:--   166
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    70  100    20  100    50     12     32  0:00:01  0:00:01 --:--:--   168
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    70  100    20  100    50     30     75 --:--:-- --:--:-- --:--:--   167
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    70  100    20  100    50     26     66 --:--:-- --:--:-- --:--:--   165
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    70  100    20  100    50     30     75 --:--:-- --:--:-- --:--:--   167
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    70  100    20  100    50     30     75 --:--:-- --:--:-- --:--:--   167
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    70  100    20  100    50     30     75 --:--:-- --:--:-- --:--:--   167
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    70  100    20  100    50     30     75 --:--:-- --:--:-- --:--:--   167
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    70  100    20  100    50     30     75 --:--:-- --:--:-- --:--:--   167
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    70  100    20  100    50     25     62 --:--:-- --:--:-- --:--:--   168
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    70  100    20  100    50      6     15  0:00:03  0:00:03 --:--:--    22
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    69  100    20  100    49     30     73 --:--:-- --:--:-- --:--:--   160
What do they mean?
Regarding the live data are zero: On which base does 123solar evaluate, that the data are too old? I think we will have to modify the modpoll program.
Cheers,
Mario

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests