Page 5 of 14

Re: meterN 0.7

Posted: Mon Apr 06, 2015 10:55 am
by jeanmarc
Hi,

meterN 0.7.5 is released and correct few minors bugs (timezone, etc..)
Also some comapps examples have been reworked.

Happy easter monday

Re: meterN 0.7

Posted: Wed Apr 08, 2015 4:59 pm
by Pongo
Hello,
there is a problem on new version

Code: Select all

[08-Apr-2015 17:49:14 Europe/Rome] PHP Warning:  include(../scripts/memory.php): failed to open stream: No such file or directory in /var/www/metern0.7.5/admin/admin.php on line 43
[08-Apr-2015 17:49:14 Europe/Rome] PHP Warning:  include(): Failed opening '../scripts/memory.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/metern0.7.5/admin/admin.php on line 43
file scripts/memory.php is missing

Code: Select all

diff -urN metern-0.7.4/scripts/memory.php metern-0.7.5/scripts/memory.php
--- metern-0.7.4/scripts/memory.php     2015-03-09 08:49:21.000000000 +0100
+++ metern-0.7.5/scripts/memory.php     1970-01-01 01:00:00.000000000 +0100
@@ -1,8 +0,0 @@
-<?php
-//Shared Memory usage
-// live things
-$LIVEMEMORY = 843;
-$ILIVEMEMORY = 844;
-// 5minflag + total counters + mail Q
-$MEMORY   = 845;
-?>
after copying

Code: Select all

pi@pi-alarm /var/www/metern0.7.5/scripts $ sudo cp ../../metern0.7.4/scripts/memory.php .
meterN starts regularly

Regards

Re: meterN 0.7

Posted: Wed Apr 08, 2015 5:24 pm
by jeanmarc
Oh sorry i forgot this file. I've repack the version, thanks

Re: meterN 0.7

Posted: Tue Apr 14, 2015 9:34 am
by megamarco83
hi, using this new version of meterN 0.7.3 is not working the command:
curl http://localhost/metern/comapps/pool123s.php?cmd=2
because when i run the test, this is the message that i receive:
Direct access not permitted is not valid, the correct format is 1(1234.5*Wh)
same story also the live pooling
curl http://localhost/metern/comapps/pool123s.php?cmd=1
what i have to change in eflow.php and in pool123s.php (that in previous version was named pool123solar.php)
thanks so much for help
regards

Re: meterN 0.7

Posted: Tue Apr 14, 2015 10:21 am
by jeanmarc
Hi,
The lastest is 0.7.5 also pool123s example have been redesigned
You will need to setup the path to 123, your inverter number and your meter id then
ln -s /srv/http/metern/comapps/pool123s.php /usr/bin/pool123s
Request Main command with 'pool123s energy' and live command 'pool123s power

Re: meterN 0.7

Posted: Tue Apr 14, 2015 11:01 am
by megamarco83
hi! thanks for reply, i follow your suggestion, and update to 0.7.5 and create the link:
ln -s /var/www/metern/comapps/pool123s.php /usr/bin/pool123s (/var/www/ is where i placed meterN)

i set up pool123s.php:
// 123solar config
$pathto123s = '/var/www/123solar';
$invtnum = 1;

// meterN config
$METERID = 1;
$INVTmetnum = 1; // meter meterN number

and i set up also eflow.php :

Code: Select all

// Setup your virtual meters identification numbers :
$whinmet = 3; // Wh in
$whoutmet = 4; // Wh out 
$selfcmet = 5; // selfconsumption

define('checkaccess', TRUE);
include('var/www/metern/config/config_main.php');
date_default_timezone_set($DTZ);

for ($i = 1; $i <= $NUMMETER; $i++) { // detect the production/consumption meter
include("var/www/metern/config/config_met$i.php");
if (${'PROD' . $i} == 1) {
$prodlist[] = $i;
}
if (${'PROD' . $i} == 2) {
$conslist[] = $i;
}
}

$dir = '/var/www/metern/data/csv/';
$output = array();
$output = glob($dir . '*.csv');
sort($output);
$cnt = count($output);

and this is pooler.php:
$pathtomn = '/var/www/metern'; 
$output = shell_exec('pkill -f poolmeters.py > /dev/null 2>&1 &'); // Kill 
temporary the "live values fetching" 
if ($argv[1] == 'elect') { 
$metnum = 2
;
$cmd = 'java -cp /var/www/metern/comapps/bin/ pv.PoolClient -c period -um Wh -cn 2';
now with command pool123s energy
1(9068105*Wh) is not valid, the correct format is Elect(1234.5*Wh)
but why i obtain this numer with "not valid" ??

with command: pool123s power i have: 1(1698*W) is a valid entry ! and it's correct because is perfectly corrisponding on live power!

with the others sensor (3), using command: eflow whin i receive: (0*Wh) is not valid, the correct format is 3(1234.5*Wh)

and also with sensro 4: eflow whout and with sensor 5: eflow selfc same errors with sensor 2 (that are consumption) i have:
command: pooler elect
response: 2(0*Wh) is a valid entry !
but i's not correct....because the consumption is not 0wh :-(

command: java -cp /var/www/metern/comapps/bin/ pv.PoolClient -c live -um W -cn 2
same risponse: 2(0*Wh) is a valid entry !
but again is not possible :(

Re: meterN 0.7

Posted: Tue Apr 14, 2015 2:15 pm
by jeanmarc
1(9068105*Wh) is not valid, the correct format is Elect(1234.5*Wh)
Please don't mess meter's ID and number. Eg: you may use a ID of "1-0:1.8.1" and name your meter 'Elect'. Here you've set a meter ID 'Elect' and your application say it is "1".

I haven't work anymore on eflow, i don't use it. I use houseenergy/householdselfconsum.
:arrow: Mind that this are plain examples.

My guess is that you didn't setup correcly meter's numbers in it.

Re: meterN 0.7

Posted: Tue Apr 14, 2015 2:40 pm
by megamarco83
jeanmarc wrote:
1(9068105*Wh) is not valid, the correct format is Elect(1234.5*Wh)
Please don't mess meter's ID and number. Eg: you may use a ID of "1-0:1.8.1" and name your meter 'Elect'. Here you've set a meter ID 'Elect' and your application say it is "1".

I haven't work anymore on eflow, i don't use it. I use houseenergy/householdselfconsum.
:arrow: Mind that this are plain examples.

My guess is that you didn't setup correcly meter's numbers in it.
you are right!
my mistake (of course:)) i forgot on web page to set Meter ID as 1 (it was set as elect and i didn't change!)
thanks, now with sensor 1 (production) the output of test with command: pool123s energy is:
1(9076599*Wh) is a valid entry !
but it seams a strange number....
the test with pool123s power is
1(1820*Wh) that is perfect alignet as 123solar!!


the sensor 2 is consuption
and meter id is 2
command:
output of test is: 2(0*Wh) is a valid entry !
that is not correct :(

live command is: java -cp /var/www/metern/comapps/bin/ pv.PoolClient -c live -um W -cn 2
and the output is: 2(0*Wh) is a valid entry !
not correct

the sensor 3 is "taking energy"
and meter id is 3
command: eflow whin
output of test is: (0*Wh) is not valid, the correct format is 3(1234.5*)
that is not correct :(



the sensor 4 is: immision
and meter id is 4
command: eflow whout
output of test is: (0*Wh) is not valid, the correct format is 3(1234.5*)
that is not correct :(



the sensor 5 is self consumption
and meter id is 5
command: eflow selfc
output of test is: (0*Wh) is not valid, the correct format is 3(1234.5*)
that is not correct :(

thanks for help, and sorry for stupid questions!!

Re: meterN 0.7

Posted: Sun Jun 28, 2015 3:41 pm
by jeanmarc
Hello,

meterN 0.7.6 is out, it is a minor release.

- Updated admin form and JS lib
- Corrected few minors bugs
- Moved com apps example into a separate package

Bye

Re: meterN 0.7.6

Posted: Sun Jul 05, 2015 4:14 pm
by ale64
Hello Jeanmarc, it is done by installing the new Metern OS 0.7.6 with pulse counter, potra GPIO and follow the guidance of "flâne", but the discharge can not find the file and pool123s.php eflow.php.
Can I use the old files in the new Metern 0.7.6.
Maybe you have an updated guide.
Thank you have a nice day.