123solar.service

Talks about solar stuff
jeanmarc
Posts: 2022
Joined: Thu Aug 29, 2013 7:16 am

Re: 123solar.service

Post by jeanmarc » Tue Jun 16, 2015 12:43 pm

Hi,
yes the permission is ok. The issue is because of the "File not found."
Check if localhost exist in your hosts file

Code: Select all

[root@odroid ~]# more /etc/hosts 
#
# /etc/hosts: static lookup table for host names
#

#<ip-address>	<hostname.domain.org>	<hostname>
127.0.0.1	localhost.localdomain	localhost odroid
::1		localhost.localdomain	localhost

jatz76
Posts: 24
Joined: Tue Feb 24, 2015 3:50 am

Re: 123solar.service

Post by jatz76 » Tue Jun 16, 2015 1:43 pm

This is hosts file:

Code: Select all

pi@rPi ~ $ more /etc/hosts
127.0.0.1       localhost
::1             localhost ip6-localhost ip6-loopback
fe00::0         ip6-localnet
ff00::0         ip6-mcastprefix
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters

127.0.1.1       rPi
I don't use ip6 so can I remove all this and just add:

Code: Select all

127.0.0.1   localhost.localdomain   localhost odroid
::1      localhost.localdomain   localhost

jatz76
Posts: 24
Joined: Tue Feb 24, 2015 3:50 am

Re: 123solar.service

Post by jatz76 » Tue Jun 16, 2015 1:50 pm

I tried setting the hosts to

127.0.0.1 localhost.localdomain localhost odroid
::1 localhost.localdomain localhost

127.0.1.1 rPi


But this hasn't worked. "/usr/bin/curl http://localhost/123solar/scripts/boot123s.php" returns "File not found."

I changed it back to the way it was.

jeanmarc
Posts: 2022
Joined: Thu Aug 29, 2013 7:16 am

Re: 123solar.service

Post by jeanmarc » Tue Jun 16, 2015 3:19 pm

hmm, does that work ?

Code: Select all

[root@odroid ~]# ping localhost
PING localhost.localdomain (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=1 ttl=64 time=0.074 ms
64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=2 ttl=64 time=0.074 ms
Did you remove the quote with the command ? ;)
ps: As far as i know Raspbian don't use systemd..

jatz76
Posts: 24
Joined: Tue Feb 24, 2015 3:50 am

Re: 123solar.service

Post by jatz76 » Tue Jun 16, 2015 9:07 pm

the ping seems to work:

ping localhost
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_req=1 ttl=64 time=0.118 ms
64 bytes from localhost (127.0.0.1): icmp_req=2 ttl=64 time=0.143 ms


And yes, not using quotes. I tried replacing localhost with the actual IP address and that also doesn't work. :?

jatz76
Posts: 24
Joined: Tue Feb 24, 2015 3:50 am

Re: 123solar.service

Post by jatz76 » Thu Jun 18, 2015 1:28 pm

Is there another way to start the logger?

jeanmarc
Posts: 2022
Joined: Thu Aug 29, 2013 7:16 am

Re: 123solar.service

Post by jeanmarc » Thu Jun 18, 2015 1:39 pm

Hi,
It does work, there is a problem on your configuration. Please post the full message.
What return curl http://localhost/123solar/index.php ?

jatz76
Posts: 24
Joined: Tue Feb 24, 2015 3:50 am

Re: 123solar.service

Post by jatz76 » Fri Jun 19, 2015 6:02 am

jeanmarc wrote:Hi,
It does work, there is a problem on your configuration. Please post the full message.
What return curl http://localhost/123solar/index.php ?
Returns: -bash: http://localhost/123solar/index.php: No such file or directory

You can see my logger from the following address: http://58.96.48.213:88/123solar/index_mono.php
All I have done is forwarded the IP/port through my router.

jeanmarc
Posts: 2022
Joined: Thu Aug 29, 2013 7:16 am

Re: 123solar.service

Post by jeanmarc » Fri Jun 19, 2015 6:49 am


jatz76
Posts: 24
Joined: Tue Feb 24, 2015 3:50 am

Re: 123solar.service

Post by jatz76 » Sun Jun 21, 2015 10:20 pm

curl http://localhost/123solar/index.php returns "File not found."

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests