Effekta / Enersolis support

others protocols
jeanmarc
Posts: 1580
Joined: Thu Aug 29, 2013 7:16 am

Re: Effekta / Enersolis support

Post by jeanmarc » Thu Jan 16, 2014 5:24 pm

Well, the efficiency is not a stable value and is especially low when a string isn't at his optimal voltage. eg :
Image
I can assure you the calcul is correct, the efficiency shown in specs is the best one, like the car's makers does with fuel consumption ;)

mstuetz
Posts: 73
Joined: Sun Dec 29, 2013 1:20 pm

Re: Effekta / Enersolis support

Post by mstuetz » Mon Jan 20, 2014 6:39 am

I agree with you.
But how can you explain the efficiency value in the 123solar details output?
Do you calculate that with the mentioned formula or do you get this from the inverters?

jeanmarc
Posts: 1580
Joined: Thu Aug 29, 2013 7:16 am

Re: Effekta / Enersolis support

Post by jeanmarc » Mon Jan 20, 2014 8:29 am

The value may be return by the inverter and coincides with the calcul.

eg with some reals values returned by my Aurora:
I1P=13.414526
I2P=15.001282
GP=1.611328
EFF=5.670535

(1.611328/28,415808)*100=5,67053381%

mstuetz
Posts: 73
Joined: Sun Dec 29, 2013 1:20 pm

Re: Effekta / Enersolis support

Post by mstuetz » Fri Jan 24, 2014 12:09 pm

Hi!
Finally we got it working fine.
I will send you the code and some installation hints by email.

I even got the whole thing running on Medion NAS. I will post the steps in a new article.

Thx for your support!

jeanmarc
Posts: 1580
Joined: Thu Aug 29, 2013 7:16 am

Re: Effekta / Enersolis support

Post by jeanmarc » Fri Jan 24, 2014 2:42 pm

Hi Mario,
Thanks for your work :) I am not sure it is wise to include your com app (modpoll) in 123s. As it is only a gui..
Maybe you could host them somewhere ? (Google code is about to close may be Codeplex ?) If you want i can host them too but you won't have "hands" on your files.. :?

mstuetz
Posts: 73
Joined: Sun Dec 29, 2013 1:20 pm

Re: Effekta / Enersolis support

Post by mstuetz » Sat Jan 25, 2014 4:05 pm

You are right!
I will post the "modpoll" code somewhere else. Just include the effekta*.php scripts and I will let you know where to get the other files.
Cheers,
Mario

mstuetz
Posts: 73
Joined: Sun Dec 29, 2013 1:20 pm

Re: Effekta / Enersolis support

Post by mstuetz » Mon Jan 27, 2014 12:40 pm

Modpoll code was released@ sourceforge.net/projects/modpoll.
Works fine so far, but we'r still working on some minor issues.

There should not be further changes on the effekta_*.php scripts.
I am looking forward to see this files in a future release of 123solar.

Thx for the great help!

mstuetz
Posts: 73
Joined: Sun Dec 29, 2013 1:20 pm

Re: Effekta / Enersolis support

Post by mstuetz » Tue Feb 25, 2014 3:11 pm

I updated the modpoll scripts for data collection on sourceforge.

Changes:
Efficiency calculation is corrected
The very inacurate power counter value of the inverter gets now only used for initial startup after installation
Many minor bug fixes

mstuetz
Posts: 73
Joined: Sun Dec 29, 2013 1:20 pm

Re: Effekta / Enersolis support

Post by mstuetz » Thu Mar 13, 2014 2:58 pm

Hi again!
We have one more little problem, which causes a spike in the visuals every ~50min.
Image
As we can see, our effekta.php script gets called 3-4 times per second from worker.
Since we poll the inverter just every 20 seconds and write the received values in temporary files, the worker gets real new data only every 20 secs. In the meantime worker and effekta.php just read the same data because there was no change in the temp files.

The 5 minutes for calculating the average power is, off course, not synced with our 20 secs rhythmus. So from time to time (~50mins) one of the 20sec. values does obviously not get taken into accound. This leads to the little bumps in the graph.

Do you have any idea, how we could get rid of this problem?
How do other interface drivers get arround that issue? I guess no inverter can send actual data much faster than every 20 secs.

Cheers,
Mario

jeanmarc
Posts: 1580
Joined: Thu Aug 29, 2013 7:16 am

Re: Effekta / Enersolis support

Post by jeanmarc » Thu Mar 13, 2014 3:44 pm

Hi Mario,

Well, aurora, sma-get and sma-spot can actually retrieve data pretty quickly.
My live things usually update at a 1 sec rate with a 1sec delay: that's appear neatly when the weather is sunny/cloudy and the gauges moves with little delay.
I don't have a trick to resolve the problem, except having a faster pooling ;)

Also, i believe it's not a good solution writing in a file each 20sec.. :|

Thanks for your coding.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest