123Solar with SMA inverter and latest version of SMAspot

SBFspot protocol http://sbfspot.codeplex.com/
Post Reply
krubik
Posts: 4
Joined: Mon Jul 21, 2014 1:10 pm

123Solar with SMA inverter and latest version of SMAspot

Post by krubik » Mon Jul 21, 2014 1:17 pm

Hello,

I tried to setup 123Solar on my Raspberry Pi, but I do not get the communication to the SMA STP5000-TL working.

Actual versions used:

123Solar: 1.6.5.5
SMAspot: V2.4.5

Communication over ethernet.
SMAspot is working:


SMAspot -q -123s=DATA -cfg/var/www/123solar/config/SMAspot_0.cfg

Code: Select all

Inverter IP address: 192.168.1.63 from SMAspot.cfg
SetInverterTime() not executed! We're still testing...
20140721-14:55:09 227.470 0.562 127.000 229.530 0.548 125.000 226.730 0.549 124.000 50.000 102.174 0.000 0.000 3471.734 366.640 0.666 244.000 179.680 0.694 124.000 229.530 1.659 376.000 >>>S123:OK
SMAspot -q -123s=INFO -cfg/var/www/123solar/config/SMAspot_0.cfg

Code: Select all

Inverter IP address: 192.168.1.63 from SMAspot.cfg
SetInverterTime() not executed! We're still testing...
Reader: SMAspot 2.4.5
Bluetooth Address:
Bluetooth NetID: 20
Time: 20140721-14:55:20
Device Name: STP 5000TL-20 513
Device Class: Solar Inverter
Device Type: STP 5000TL-20
Serial Number: 304956513
Firmware: 02.52.02.R
Pac Max Phase 1: 5000W
Pac Max Phase 2: 5000W
Pac Max Phase 3: 5000W
Wake-Up Time: 20140721-05:55:47
Sleep Time: 20140721-14:55:21
SMAspot -q -123s=STATE -cfg/var/www/123solar/config/SMAspot_0.cfg

Code: Select all

Inverter IP address: 192.168.1.63 from SMAspot.cfg
SetInverterTime() not executed! We're still testing...
Inverter Time: 20140721-14:56:35
Device Name: STP 5000TL-20 513
Device Status: Ok
GridRelay Status: Closed
Operation Time: 2133.463
Feed-In Time: 2094.033
Bluetooth Signal: 17031031405950142974525440.000

if I do a "Test communication" at the inverters configuration screen, I get the following error:

Code: Select all

/config
timeout --kill-after=10s 5s SMAspot -finq -q -123s=DATA -cfg/config/SMAspot_0.cfg return :

error : / 
the events box on the info screen shows following messages:

Code: Select all

21/07/2014 14:13:00	Connection lost for #1

21/07/2014 14:13:00 for #1 ---


21/07/2014 14:08:00	Connection lost for #1

21/07/2014 14:08:00 for #1 ---


21/07/2014 14:03:00	Connection lost for #1

21/07/2014 14:03:00 for #1 ---


21/07/2014 13:58:10 for #1 ---


21/07/2014 13:58:09	Starting 123Solar
Any help highly appreciated...

Kind regards

Klaus
Last edited by krubik on Mon Jul 21, 2014 2:02 pm, edited 1 time in total.

jeanmarc
Posts: 1606
Joined: Thu Aug 29, 2013 7:16 am

Re: 123Solar with SMA inverter and latest version of SMAspot

Post by jeanmarc » Mon Jul 21, 2014 2:02 pm

Hi,
Actually, i don't think SBFspot V2.4.5 support 123solar output, does it ?
You might have to try SMAspot 2.06a.

krubik
Posts: 4
Joined: Mon Jul 21, 2014 1:10 pm

Re: 123Solar with SMA inverter and latest version of SMAspot

Post by krubik » Mon Jul 21, 2014 2:04 pm

jeanmarc wrote:Hi,
Actually, i don't think SBFspot V2.4.5 support 123solar output, does it ?
You might have to try SMAspot 2.06a.
Then I can't use 123Solar, as SMAspot 2.0.6a does not support access via ethernet

aldesr
Posts: 14
Joined: Sun Sep 15, 2013 12:34 pm

Re: 123Solar with SMA inverter and latest version of SMAspot

Post by aldesr » Sat Aug 02, 2014 10:42 am

The 123Support is identical in all SBFspot (SMAspot) versions. And it is not bound to a particular communications protocol (= is available for bluetooth and Webconnect inverters).

Problem is here :
-----
Inverter IP address: 192.168.1.63 from SMAspot.cfg
SetInverterTime() not executed! We're still testing...
-----

This information should not present in the message frame sent to 123Solar.

( >krubik. Just contact SBF. He will arrange that :) )

piombo
Posts: 6
Joined: Sun Aug 10, 2014 10:22 am

Re: 123Solar with SMA inverter and latest version of SMAspot

Post by piombo » Sun Aug 10, 2014 10:35 am

I got a very similar setup (ethernet, SBFspot) and the same error.
Looks like that these two lines of text mess that up.
Is there a solution yet? What will we have to do to fix this?
I really appreciate your work - and I am looking forward to use 123solar!
Thanks.

aldesr
Posts: 14
Joined: Sun Sep 15, 2013 12:34 pm

Re: 123Solar with SMA inverter and latest version of SMAspot

Post by aldesr » Sat Aug 16, 2014 7:13 pm

Problem was reported to SBF.

A real solution would probably to modify the 123Solar message frames a bit (encapsulate them).

Later...

aldesr
Posts: 14
Joined: Sun Sep 15, 2013 12:34 pm

Re: 123Solar with SMA inverter and latest version of SMAspot

Post by aldesr » Sun Aug 17, 2014 10:18 pm

SBF added item to issue list :
http://sbfspot.codeplex.com/workitem/46

Issue already closed (FIXED)
2.4.5a is available for download

jeanmarc
Posts: 1606
Joined: Thu Aug 29, 2013 7:16 am

Re: 123Solar with SMA inverter and latest version of SMAspot

Post by jeanmarc » Mon Aug 18, 2014 6:54 am

Many thanks to SBF :)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest