123solar not work

SBFspot protocol http://sbfspot.codeplex.com/
febpro
Posts: 14
Joined: Fri Mar 21, 2014 6:45 pm

123solar not work

Post by febpro » Thu May 01, 2014 10:53 am

now 123solar not work
yesterday is OK
in .../123solar/admin/help.php
i see:

Code: Select all

Shared memory : (148384 bytes - 256 kb)
Memory (#321)
Array ( [awake] => 0 [pmotd1] => 0 [pmotdt1] => 1398936567 [pmotdmulti] => 0 [pmotdtmulti] => 1398936567 [invtstat1] => Inverter Time: 20140501-11:35:33 Device Name: SN: 2130062871 Device Status: OK GridRelay Status: Closed Operation Time: 7052.948 Feed-In Time: 6809.682 Bluetooth Signal: 73.725 There is no data to export! [5minflag1] => [mailq1] => 0 [AWt1] => 1398936900 [AWriso1] => 0 [AWileak1] => 0 [peakotd1] => 0 [peakoat1] => 0 )
Live Memory (#524)
Array ( [SDTE1] => 1398937338 [I1V1] => 0 [I1A1] => 0 [I1P1] => 0 [I2V1] => 0 [I2A1] => 0 [I2P1] => 0 [I3V1] => 0 [I3A1] => 0 [I3P1] => 0 [I4V1] => 0 [I4A1] => 0 [I4P1] => 0 [G1V1] => 0 [G1A1] => 0 [G1P1] => 0 [G2V1] => 0 [G2A1] => 0 [G2P1] => 0 [G3V1] => 0 [G3A1] => 0 [G3P1] => 0 [FRQ1] => 0 [EFF1] => 0 [INVT1] => 0 [BOOT1] => 0 [SSR1] => 0 [KWHT1] => 0 ) 
I test with comand (console with putty)

./SMAspot -q -123s

Code: Select all

root@raspberrypi:/home/pi/smaspot/bin/Release# ./SMAspot -q -123s
20140501-11:37:28 217.080 5.866 1273.000 0.000 0.000 0.000 0.000 0.000 0.000 49.980 95.427 0.000 0.000 6922.047 293.670 2.821 827.000 200.640 2.530 507.000 217.080 5.866 1273.000 >>>S123:OK
There is no data to export!
./SMAspot -q -123s=SYNC

Code: Select all

root@raspberrypi:/home/pi/smaspot/bin/Release# ./SMAspot -q -123s=SYNC
There is no data to export!
./SMAspot -q -123s=INFO

Code: Select all

root@raspberrypi:/home/pi/smaspot/bin/Release# ./SMAspot -q -123s=INFO
Reader: SMAspot 2.0.6a
Bluetooth Address: 00:80:25:26:1B:F9
Bluetooth NetID: 02
Time: 20140501-11:40:48
Device Name: SN: 2130062871
Device Class: Solar Inverters
Device Type: SB4000TL-21
Serial Number: 2130062871
Firmware: 02.50.13.R
Wake-Up Time: 20140501-06:04:07
Sleep Time: 20140501-11:40:48
There is no data to export!
./SMAspot -q -123s=STATE

Code: Select all

root@raspberrypi:/home/pi/smaspot/bin/Release# ./SMAspot -q -123s=STATE
Inverter Time: 20140501-11:42:03
Device Name: SN: 2130062871
Device Status: OK
GridRelay Status: Closed
Operation Time: 7053.057
Feed-In Time: 6809.791
Bluetooth Signal: 73.725
There is no data to export!
I see to .../123solar/programs/programlive.php

Code: Select all

[{"SDTE":1398937541000,"I1V":0,"I1A":0,"I1P":0,"I2V":0,"I2A":0,"I2P":0,"I3V":0,"I3A":0,"I3P":0,"I4V":0,"I4A":0,"I4P":0,"G1V":0,"G1A":0,"G1P":0,"G2V":0,"G2A":0,"G2P":0,"G3V":0,"G3A":0,"G3P":0,"FRQ":0,"EFF":0,"INVT":0,"BOOT":0,"SSR":0,"PMAXOTD":0,"PMAXOTDTIME":0,"timestamp":"01\/05\/2014 11:45:41","riso":0,"ileak":0,"awdate":"--:--"}]

if I turn off 123solar
and manually sending the command to smaspot
smaspot console responds with the correct data is written to the data and also on pvoutput.org

I tried to figure out if it is a permissions problem

I replaced the sd card with
new sd card with working image
the same

Help thank you
ciao Fabio

http://fvfebpro.tk

jeanmarc
Posts: 1601
Joined: Thu Aug 29, 2013 7:16 am

Re: 123solar not work

Post by jeanmarc » Thu May 01, 2014 11:11 am

enable debug and check what return scripts/123solar.err.
It is abnormal that the 'awake' flag isn't to 1 whether it is day on your side.
btw programlive need to be invoke with the invtnum as follow : programlive.php?invtnum=1

febpro
Posts: 14
Joined: Fri Mar 21, 2014 6:45 pm

Re: 123solar not work

Post by febpro » Thu May 01, 2014 1:13 pm

Hi
I have enabled debug in main configuration
how check script /123solar.err ?

I see in admin help
Shared memory :

Code: Select all

(148352 bytes - 256 kb)
Memory (#321)
Array ( [awake] => 1 [pmotd1] => 0 [pmotdt1] => 1398936567 [pmotdmulti] => 0 [pmotdtmulti] => 1398936567 [invtstat1] => Inverter Time: 20140501-13:57:33 Device Name: SN: 2130062871 Device Status: OK GridRelay Status: Closed Operation Time: 7055.315 Feed-In Time: 6812.049 Bluetooth Signal: 73.333 There is no data to export! [5minflag1] => [mailq1] => 0 [AWt1] => 1398945420 [AWriso1] => 0 [AWileak1] => 0 [peakotd1] => 0 [peakoat1] => 0 )
Live Memory (#524)
Array ( [SDTE1] => 1398937338 [I1V1] => 0 [I1A1] => 0 [I1P1] => 0 [I2V1] => 0 [I2A1] => 0 [I2P1] => 0 [I3V1] => 0 [I3A1] => 0 [I3P1] => 0 [I4V1] => 0 [I4A1] => 0 [I4P1] => 0 [G1V1] => 0 [G1A1] => 0 [G1P1] => 0 [G2V1] => 0 [G2A1] => 0 [G2P1] => 0 [G3V1] => 0 [G3A1] => 0 [G3P1] => 0 [FRQ1] => 0 [EFF1] => 0 [INVT1] => 0 [BOOT1] => 0 [SSR1] => 0 [KWHT1] => 0 ) 
Checking Software

Code: Select all

www-data  3434     1  0 11:42 ?        00:00:56 php ../scripts/123solar.php
www-data 15771  3434  0 13:59 ?        00:00:00 sh -c timeout --kill-after=10s 5s SMAspot -finq -q -123s=DATA -cfg/var/www/123solar/config/SMAspot_1.cfg -Y3 -l3
www-data 15772 15771  0 13:59 ?        00:00:00 timeout --kill-after=10s 5s SMAspot -finq -q -123s=DATA -cfg/var/www/123solar/config/SMAspot_1.cfg -Y3 -l3
www-data 15773 15772  6 13:59 ?        00:00:00 SMAspot -finq -q -123s=DATA -cfg/var/www/123solar/config/SMAspot_1.cfg -Y3 -l3
I send .../123solar/programs/programlive.php?invtnum=1

Code: Select all

[{"SDTE":1398945457000,"I1V":0,"I1A":0,"I1P":0,"I2V":0,"I2A":0,"I2P":0,"I3V":0,"I3A":0,"I3P":0,"I4V":0,"I4A":0,"I4P":0,"G1V":0,"G1A":0,"G1P":0,"G2V":0,"G2A":0,"G2P":0,"G3V":0,"G3A":0,"G3P":0,"FRQ":0,"EFF":0,"INVT":0,"BOOT":0,"SSR":0,"PMAXOTD":0,"PMAXOTDTIME":0,"timestamp":"01\/05\/2014 13:57:37","riso":0,"ileak":0,"awdate":"--:--"}]
I work with 123Solar 1.6.5.3 and SMAspot 2.06a

ciao
Fabio
from Italy

I remember
yesterday is OK; raspberry has remained ON and today 123solar KO
http://fvfebpro.tk

jeanmarc
Posts: 1601
Joined: Thu Aug 29, 2013 7:16 am

Re: 123solar not work

Post by jeanmarc » Thu May 01, 2014 1:23 pm

You need to start/stop in order to make the debug active. Then return "123Solar errors log" in help page.

febpro
Posts: 14
Joined: Fri Mar 21, 2014 6:45 pm

Re: 123solar not work

Post by febpro » Thu May 01, 2014 1:27 pm

ok
stop and start

I see:

Code: Select all

01/05/2014 14:23:52	Stopping 123Solar

01/05/2014 14:24:04	Starting 123Solar

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100    62  100    55  100     7     79     10 --:--:-- --:--:-- --:--:--   158
PHP Notice:  Undefined variable: invt_num in /var/www/123solar/config/loadcfg.php on line 123
PHP Notice:  Undefined variable: SKIPMONITORING in /var/www/123solar/config/loadcfg.php on line 123
PHP Warning:  shmop_open(): unable to attach or create shared memory segment in /var/www/123solar/config/loadcfg.php on line 216
PHP Warning:  shmop_delete(): no shared memory segment with an id of [0] in /var/www/123solar/config/loadcfg.php on line 217
PHP Warning:  shmop_close(): no shared memory segment with an id of [0] in /var/www/123solar/config/loadcfg.php on line 218
cp: cannot stat `/var/www/123solar/data/invt1/errors/de.err': No such file or directory
cp: cannot stat `/var/www/123solar/data/invt1/errors/de.err': No such file or directory
cp: cannot stat `/var/www/123solar/data/invt1/errors/de.err': No such file or directory
Checking Software :

Code: Select all

www-data 18022     1 12 14:24 ?        00:00:27 php ../scripts/123solar.php
ciao
Fabio
http://fvfebpro.tk

jeanmarc
Posts: 1601
Joined: Thu Aug 29, 2013 7:16 am

Re: 123solar not work

Post by jeanmarc » Thu May 01, 2014 4:07 pm

You've probably mess-up with permissions. Did you edit config manually ?
chmod 666 config/config*
You might also do a ipcrm -M 321 to clear memory.

febpro
Posts: 14
Joined: Fri Mar 21, 2014 6:45 pm

Re: 123solar not work

Post by febpro » Fri May 02, 2014 8:00 am

Hi Jeanmarc

I try chmod 666 config/config* but is not solution

I am start from new SD card
I installed everything again
No OK !
I have set 123solar in debugging

Checking Software :

Code: Select all

www-data 13861     1 12 08:41 ?        00:00:07 php ../scripts/123solar.php
123Solar errors log :

Code: Select all

02/05/2014 08:34:22	Starting 123Solar

PHP Warning:  shmop_size(): no shared memory segment with an id of [0] in /var/www/123solar/config/loadcfg.php on line 36
PHP Warning:  shmop_close(): no shared memory segment with an id of [0] in /var/www/123solar/config/loadcfg.php on line 37
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100    62  100    55  100     7     75      9 --:--:-- --:--:-- --:--:--   166
PHP Warning:  shmop_open(): unable to attach or create shared memory segment in /var/www/123solar/config/loadcfg.php on line 206
PHP Warning:  shmop_delete(): no shared memory segment with an id of [0] in /var/www/123solar/config/loadcfg.php on line 207
PHP Warning:  shmop_close(): no shared memory segment with an id of [0] in /var/www/123solar/config/loadcfg.php on line 208
/var/www/123solar/configcp: cannot stat `/var/www/123solar/data/invt1/errors/de.err': No such file or directory
ar/www/123solar/configcp: cannot stat `/var/www/123solar/data/invt1/errors/de.err': No such file or directory
/var/www/123solar/configcp: cannot stat `/var/www/123solar/data/invt1/errors/de.err': No such file or directory
/var/www/123solar/configPHP Notice:  Undefined offset: -1 in /var/www/123solar/scripts/123solar.php on line 417
PHP Warning:  file(): Filename cannot be empty in /var/www/123solar/scripts/123solar.php on line 418
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100    63  100    20  100    43     31     66 --:--:-- --:--:-- --:--:--   142
cp: cannot stat `/var/www/123solar/data/invt1/errors/de.err': No such file or directory
/var/www/123solar/configcp: cannot stat `/var/www/123solar/data/invt1/errors/de.err': No such file or directory
/var/www/123solar/configcp: cannot stat `/var/www/123solar/data/invt1/errors/de.err': No such file or directory
/var/www/123solar/configcp: cannot stat `/var/www/123solar/data/invt1/errors/de.err': No such file or directory
/var/www/123solar/config02/05/2014 08:39:54	Stopping 123Solar

cp: cannot stat `/var/www/123solar/data/invt1/errors/de.err': No such file or directory
02/05/2014 08:41:03	Starting 123Solar

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100    62  100    55  100     7     82     10 --:--:-- --:--:-- --:--:--   171
100    62  100    55  100     7     81     10 --:--:-- --:--:-- --:--:--   169
/var/www/123solar/configcp: cannot stat `/var/www/123solar/data/invt1/errors/de.err': No such file or directory
/var/www/123solar/configcp: cannot stat `/var/www/123solar/data/invt1/errors/de.err': No such file or directory
/var/www/123solar/configcp: cannot stat `/var/www/123solar/data/invt1/errors/de.err': No such file or directory
Checking communication app :
Current settings are -b -c -T -Y3 -l3 -d0 -e /dev/ttyUSB0 2> data/errors/de.err
Inverters communication errors (You have to enable debug to get all details)

Code: Select all

Use -? for help
Shared memory : (149200 bytes - 1 mb)

Code: Select all

Memory (#321)
Array ( [awake] => 1 [pmotd1] => 0 [pmotdt1] => 1399012464 [pmotdmulti] => 0 [pmotdtmulti] => 1399012464 [invtstat1] => Inverter Time: 20140502-08:41:36 Device Name: SN: 2130062871 Device Status: OK GridRelay Status: Closed Operation Time: 7064.253 Feed-In Time: 6820.301 Bluetooth Signal: 72.941 [5minflag1] => [mailq1] => 0 [AWt1] => 1399012860 [AWriso1] => 0 [AWileak1] => 0 [peakotd1] => 0 [peakoat1] => 0 )

Code: Select all

Live Memory (#524)
Array ( [SDTE1] => 1399012864 [I1V1] => 0 [I1A1] => 0 [I1P1] => 0 [I2V1] => 0 [I2A1] => 0 [I2P1] => 0 [I3V1] => 0 [I3A1] => 0 [I3P1] => 0 [I4V1] => 0 [I4A1] => 0 [I4P1] => 0 [G1V1] => 0 [G1A1] => 0 [G1P1] => 0 [G2V1] => 0 [G2A1] => 0 [G2P1] => 0 [G3V1] => 0 [G3A1] => 0 [G3P1] => 0 [FRQ1] => 0 [EFF1] => 0 [INVT1] => 0 [BOOT1] => 0 [SSR1] => 0 [KWHT1] => 0 ) 
thank you for your help

I do not understand why it worked before
only change month

Regards
Fabio

jeanmarc
Posts: 1601
Joined: Thu Aug 29, 2013 7:16 am

Re: 123solar not work

Post by jeanmarc » Fri May 02, 2014 8:08 am

I bet you didn't extract the good loadcfg.php did you ? :?

febpro
Posts: 14
Joined: Fri Mar 21, 2014 6:45 pm

Re: 123solar not work

Post by febpro » Fri May 02, 2014 8:39 am

sorry I do not understand
I forgot something?

jeanmarc
Posts: 1601
Joined: Thu Aug 29, 2013 7:16 am

Re: 123solar not work

Post by jeanmarc » Fri May 02, 2014 10:54 am

unpack the latest version and use the correct config/loadcfg.php. It doesn't seem correct to me..

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest