Problem opening serial device, check device name

Talks about solar stuff
Post Reply
jerrymex
Posts: 13
Joined: Fri May 03, 2019 11:56 pm

Problem opening serial device, check device name

Post by jerrymex » Fri Jan 17, 2020 10:46 pm

Linux alarmpi 4.19.93-2-ARCH #1 SMP PREEMPT Sat Jan 11 20:09:42 UTC 2020 armv7l GNU/Linux

123Solar 1.8.3.3
debug:

http 13153 1 10 15:34 ? 00:00:35 php 123solar.php
root 16057 23597 0 15:34 pts/1 00:00:00 less /etc/systemd/system/123solar.service

20200117-15:37:00: aurora: Problem opening serial device, check device name.

#invt1 0 Wh 0 W 0 V

Send for SYSID 67111 : 20200117 15:35 - 0 Wh 0 W 0 V C
Consumption : daily energy Wh Avg. power W
Extended data : v7 0 v8 0 v9 v10 124 v11 v12 365

PVoutput returned: OK 200: Added Status

Tried to test the communication with the inverter from the gui, shows error.
Copy the command and paste into terminal window and as user run
aurora -a 2 -c -T -Y5 -d0 -e /dev/ttyUSB0 it returns:
20200117-15:44:10 202.880142 5.710093 1158.464478 205.529221 5.617449 1154.549927 213.083405 10.424191 2215.767578 59.975052 95.795670 54.565800 51.122013 15.118 99.049 0.000 275.511 275.511 30235.654 30235.508 OK

Kinda stuck and could use some advice.
Thanks

jeanmarc
Posts: 1917
Joined: Thu Aug 29, 2013 7:16 am

Re: Problem opening serial device, check device name

Post by jeanmarc » Sat Jan 18, 2020 7:35 am

What error does it return from admin interface ?
Which version of PHP do you have ?

jerrymex
Posts: 13
Joined: Fri May 03, 2019 11:56 pm

Re: Problem opening serial device, check device name

Post by jerrymex » Sat Jan 18, 2020 12:39 pm

PHP version: 7.4.1

aurora -a 2 -c -T -Y5 -d0 -e /dev/ttyUSB0 return :

error : /

jeanmarc
Posts: 1917
Joined: Thu Aug 29, 2013 7:16 am

Re: Problem opening serial device, check device name

Post by jeanmarc » Sat Jan 18, 2020 12:55 pm


jerrymex
Posts: 13
Joined: Fri May 03, 2019 11:56 pm

Re: Problem opening serial device, check device name

Post by jerrymex » Sat Jan 18, 2020 2:51 pm

That seems to have fixed the problem, the sun is just rising, so I'll keep an eye on it.
Thanks for the pointer.

jeanmarc
Posts: 1917
Joined: Thu Aug 29, 2013 7:16 am

Re: Problem opening serial device, check device name

Post by jeanmarc » Sat Jan 18, 2020 4:01 pm

you're welcome, i have yet to rewrite the 123s debugger.
Let me know if you still have issue.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest