Page 1 of 1

v1.7.1 install error

Posted: Thu Jan 11, 2018 4:37 pm
by chrisarcher
Hi,
I have just tried updating to 1.7.1 and I get the following error :


ERROR: mv /var/www/123solar/ /var/www/123solar.20180111/

The update didn't complete as expected !

CURDIR: /var/www/123solar
SRVDIR: /var/www/123solar
SELFDIR: /admin


Now when I go back to the main page I get :

404 Not Found
nginx/1.6.2


I am running on a Rpi2 with Jessie. How can I either get my previous version working again, or install the update?

Thanks,
Chris

Re: v1.7.1 install error

Posted: Thu Jan 11, 2018 4:40 pm
by jeanmarc
Hi,
From which version did you update ?
Make sure /var/www/ is owned by the webserver user (chown -R www-data:www-data /var/www/)

Re: v1.7.1 install error

Posted: Thu Jan 11, 2018 4:50 pm
by chrisarcher
Sorry - it was from v1.7.0. I had already set the permissions as you said (chown -R www-data:www-data /var/www/) when I did the previous update.
Thanks
Chris

Re: v1.7.1 install error

Posted: Thu Jan 11, 2018 5:05 pm
by jeanmarc
What's strange is that your server dir is /var/www/123solar or it should be /var/www/.
Did you change your webserver config ? 123s should be installed on base directory.

Also, moving output the error because it can't write in /var/www/ as www user.

Re: v1.7.1 install error

Posted: Thu Jan 11, 2018 5:10 pm
by chrisarcher
I don't remember - but I suppose I must have.
In my nginx.conf file I have :

root /var/www/123solar;

Re: v1.7.1 install error

Posted: Thu Jan 11, 2018 5:29 pm
by chrisarcher
When I look in the folder I see this :
pi@raspberrypi:/var/www $ ls
123solar.20170823 123solar.20180111 html

... so it does seem to have done the mv command? You can see the 123solar folder from the v1.7.0 update last August.

Re: v1.7.1 install error

Posted: Thu Jan 11, 2018 5:30 pm
by jeanmarc
I guess that's the problem ;)
Change you webserver config and restart it.
You can rename 123solar.20180111/ to 123solar/ and try the update ?

Re: v1.7.1 install error

Posted: Thu Jan 11, 2018 5:31 pm
by chrisarcher
So do I need to change the nginx.conf file? How come it worked for the v1.7.0 update?

Re: v1.7.1 install error

Posted: Thu Jan 11, 2018 5:35 pm
by jeanmarc
I dunno..
You can then create this index.html page on base server directory if you wish to redirect :

Code: Select all

<html>
<head>
<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
<meta http-equiv="refresh" content="0; url=123solar" />
<title>Redirection html</title>
<meta name="robots" content="noindex,follow" />
</head>
</html>

Re: v1.7.1 install error

Posted: Fri Jan 12, 2018 1:44 pm
by chrisarcher
Thanks for that - its all working on v1.7.1. I left the root at var/www and put the index.html in as you said and the redirect works fine.

Many thanks for you help.
Chris