123solar 1.7.0

Talks about solar stuff
jeanmarc
Posts: 1521
Joined: Thu Aug 29, 2013 7:16 am

Re: 123solar 1.7.0

Post by jeanmarc » Thu Jan 11, 2018 3:37 pm

Hello,

123solar 1.7.1 is out :

- Updated to Highcharts 6
- Use 'annotations' for max/last power on index
- Rework for rpinotify 2.0
- Usual clean up

Bye

jeanmarc
Posts: 1521
Joined: Thu Aug 29, 2013 7:16 am

Re: 123solar 1.7.0

Post by jeanmarc » Mon Mar 05, 2018 9:09 am

Hi,

123solar 1.7.2 is out :

- Updt annotation
- Bug showing daily value in production data (older than a year)
- Bug might show running on reboot while getting a problem on starting boot123s
- Bug daemon check
- Rework startup/stop
- Usual clean up and updated JS libs

Bye

jeanmarc
Posts: 1521
Joined: Thu Aug 29, 2013 7:16 am

Re: 123solar 1.7.0

Post by jeanmarc » Thu Jun 07, 2018 7:47 am

Hi,

123solar 1.7.3 is released :

- Removed DAEMONMODE, you need to save inverter(s) config(s)
- Removed PORT option for 485solar-get
- Allow to set IP adress for eth protocols (fronius, kaco, piko)
- Reworked piko stat protocol
- Updated updater
- Disalllow huge log files
- Main page bug with IE bug (JS foreach)

Bye

flane
Posts: 79
Joined: Mon Aug 11, 2014 7:22 am

Re: 123solar 1.7.0

Post by flane » Fri Jun 08, 2018 2:08 pm

Hi Jeanmarc,
as always a great job. :)
Thank you ;)

I report a problem with the sdm120c protocol.

The integrated protocol does not work (did not work even in previous versions).
HERE you will find a modified and working version

... if you can integrate it in the next version ....

jeanmarc
Posts: 1521
Joined: Thu Aug 29, 2013 7:16 am

Re: 123solar 1.7.0

Post by jeanmarc » Fri Jun 08, 2018 3:11 pm

Hi Flane,
thanks for the feedback, i'll include that

pd1acf
Posts: 33
Joined: Mon Jan 05, 2015 6:58 pm

Re: 123solar 1.7.0

Post by pd1acf » Sun Jun 17, 2018 7:47 pm

Hi Jean-Marc,

Since updating to 1.7.3 my 123solar sometimes goes into 'off' mode all of the sudden and stops logging.

I have run it once in debug mode to see if any errors appear but after the last unexpected 'stop', nothing special can be found in the log.
Yesterday evening my 123solar was found stopped, and these are the last lines in the log:

Code: Select all

Wait for GetDeviceHandles 0
Device detect timeout, or device_nr not found
Detect daemon...
Trying to connect...
No daemon found
   Selected Options:
      debug        :1      data         :1      events       :0
      alarms       :0      info         :0      comments     :0
      help         :0      initcommport :1      status       :0
      synchrone    :0      DeviceNr     :0      StartDaemon  :0
      DaemonState  :0      RequestDaemon:0      monitor      :0
      Version      :0      ExitDaemon   :0
yasdiMasterInitialize /etc/yasdi.ini
yasdiMasterSetDriverOnline
DoStartDeviceDetection asyc ...
Wait for GetDeviceHandles 0
Wait for GetDeviceHandles 0
Wait for GetDeviceHandles 0
Wait for GetDeviceHandles 0
Wait for GetDeviceHandles 0
Wait for GetDeviceHandles 0
Wait for GetDeviceHandles 0
Wait for GetDeviceHandles 0
Wait for GetDeviceHandles 0
Wait for GetDeviceHandles 0
Wait for GetDeviceHandles 0
Wait for GetDeviceHandles 0
Wait for GetDeviceHandles 0
Wait for GetDeviceHandles 0
Wait for GetDeviceHandles 0
Wait for GetDeviceHandles 0
Device detect timeout, or device_nr not found
Device detect timeout, or device_nr not found
Device detect timeout, or device_nr not found
Device detect timeout, or device_nr not found
Device detect timeout, or device_nr not found
Device detect timeout, or device_nr not found

I'm using the Yasdi protocol for the inverter, and I do not believe there are new settings?

Please me know how to further troubleshoot this issue...

Ron

jeanmarc
Posts: 1521
Joined: Thu Aug 29, 2013 7:16 am

Re: 123solar 1.7.0

Post by jeanmarc » Mon Jun 18, 2018 4:22 pm

Hi Ron,
What do you mean by 'goes off' is it the big button ? Check if 123s is running when that happen "ps -ef | grep 123solar"
Also is there a scripts/123solar.pid file ? Does it correspond to the running process ?

pd1acf
Posts: 33
Joined: Mon Jan 05, 2015 6:58 pm

Re: 123solar 1.7.0

Post by pd1acf » Tue Jun 19, 2018 7:20 am

Hi Jean-Marc,

Yes, this is the 'big' on/off switch in the first Admin page. During operation something happens, stopping 123solar (metern does continue).

In that situation, there is no running process anymore :

Code: Select all

root@raspberry_mk:/home/pi# ps aux|grep 123
root     11582  0.0  0.3   4364  1804 pts/0    S+   08:12   0:00 grep 123
The PID file does still exist:

Code: Select all

root@raspberry_mk:/home/pi# ls -al /usr/share/nginx/www/123solar/scripts/123solar.pid
-rw-r--r-- 1 www-data www-data 5 Jun 18 17:27 /usr/share/nginx/www/123solar/scripts/123solar.pid

It shows the previous PID:

Code: Select all

root@raspberry_mk:/home/pi# cat /usr/share/nginx/www/123solar/scripts/123solar.pid
13973root@raspberry_mk:/home/pi#

But that process is gone:

Code: Select all

root@raspberry_mk:/home/pi# ps aux|grep 13973
root     11630  0.0  0.3   4364  1808 pts/0    S+   08:18   0:00 grep 13973

I will leave it off for today in case you require some other info....

Thanks,

Ron


jeanmarc wrote:
Mon Jun 18, 2018 4:22 pm
Hi Ron,
What do you mean by 'goes off' is it the big button ? Check if 123s is running when that happen "ps -ef | grep 123solar"
Also is there a scripts/123solar.pid file ? Does it correspond to the running process ?

jeanmarc
Posts: 1521
Joined: Thu Aug 29, 2013 7:16 am

Re: 123solar 1.7.0

Post by jeanmarc » Tue Jun 19, 2018 10:47 am

Hello Ron,
I guess 123s process die because of SBFspot "Device detect timeout". Maybe you can increase the $timeout_setup in protocols/SBFspot.php ?
Also, does SBF return something when 123s stop ?

pd1acf
Posts: 33
Joined: Mon Jan 05, 2015 6:58 pm

Re: 123solar 1.7.0

Post by pd1acf » Tue Jun 19, 2018 6:37 pm

Jean-Marc,

Thank you for the feedback, but I wonder if we are on the same page. I am using Yasdi protocol RS485 from SMA inverter.
I'm not using the SBFspot software, but 485solar-get software!

I did change the value, but wonder if this would make sense...

Best regards,

Ron


jeanmarc wrote:
Tue Jun 19, 2018 10:47 am
Hello Ron,
I guess 123s process die because of SBFspot "Device detect timeout". Maybe you can increase the $timeout_setup in protocols/SBFspot.php ?
Also, does SBF return something when 123s stop ?

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests