Frustrating problem to resolv names

A category for tips and tricks or off-topic things
Post Reply
Micke
Posts: 45
Joined: Sun Sep 01, 2013 1:25 pm

Frustrating problem to resolv names

Post by Micke » Wed Sep 18, 2013 6:25 pm

Hi.

I cant find any solution how to fix that my RPi resolve addresses. Without it, no connection to PVoutput (or upgrading system or whatever). I have read tons of sites and tried several solutions but there is still the same problem.
Every first time I rebuild the system from scratch there is no problem. I have to set a static address because the RPi are in DMZ. And from here my problem starts.

There is no problem to browse from internet to the RPi http://91.195.225.68/123solar. I also can ping ipaddresses but no www-addresses from a terminal. I edit the resolv.conf and set some DNS ip:s. The first one is my company's DNS-server.

[root@logger ~]# cat /etc/resolv.conf
# Generated by resolvconf
nameserver 195.5.118.6
nameserver 8.8.8.8
nameserver 8.8.4.4
[root@logger ~]#

No problem to ping an IP......
[root@logger ~]# ping 195.5.118.6
PING 195.5.118.6 (195.5.118.6) 56(84) bytes of data.
64 bytes from 195.5.118.6: icmp_seq=1 ttl=58 time=1.37 ms
64 bytes from 195.5.118.6: icmp_seq=2 ttl=58 time=2.61 ms
64 bytes from 195.5.118.6: icmp_seq=3 ttl=58 time=1.14 ms

Trying to ping a name get this result...
[root@logger ~]# ping bbc.co.uk
ping: unknown host bbc.co.uk


I suppose that I must tell the system to look in the resolv.conf file but I don't know how to do. The second problem is that after a reboot, the time and date sets to year 1970 and cant resolve a NTP to set the actual time. And 123solar won't start.
It's a kind of Moment 22.


Please help me someone :cry:
/Micke

(no smiley's that smash the head in the wall).

jeanmarc
Posts: 1867
Joined: Thu Aug 29, 2013 7:16 am

Re: Frustrating problem to resolv names

Post by jeanmarc » Wed Sep 18, 2013 6:58 pm

Hi,
It me be better to ask on Raspberry forum, maybe this could help.
Why don't you leave your Rpi with DHCP and assign a fixed IP in your router ?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest